How to get a new security to show in your Entity View (Fund View)

A client purchased shares from a new security listed in the ASX. So since it was there in the list, i didn’t manually create or add the new security. So i created the relevant investment accounts for the security instead, to record the share purchase.
However, after this, the new security does not appear under my “Entity View”. It appears only after i search in the “Global View”.
Also, when recording the share purchase, the “units” row does not appear when recording the transaction or the “More Details” drop down to record the additional investment details.
How do i get this security to come under my fund/entity?

Hi @qwerty123

Thank you for your post on the BGL Community.

With regards to your first query, it sounds like the security hasn’t been attached to the fund yet which is why it doesn’t appear in the Entity View - Please see below on how to do this through the Chart of Accounts:

With regards to your second query when recording the Share Purchase, please ensure that the security is attached to the fund and that the correct Investment Account is selected which is usually in the 70000 range. Eg 77600/BHP.AX

I hope this helps with your queries!

Hi. Thanks for the reply. But, when i go to enter the security name for the “Securities: Select Security” row, i clicked the security name from the drop down box but then after that entire row just disappears; as you can see in the pic below.

Also, i already attached the security to the relevant fund.

Also, to just add on, i don’t get this “Global View or Entity View” option here in my COA.

When i click the security name to add it, the row just disappears after i click the relevant security name; as you can see below:
image

image

Hi @qwerty123

The reason you don’t have the Global View / Entity View toggle is most likely due to your user role permission. Please contact your firm administrator to enable Fund and Global View.

With regards to the investment account loosing the security attached, it might be due to the System - More Details Label within the account more details being incorrectly set to “System - Non-Unitised Investment”. It has to be set to “System - Unitised Investment”.

I hope this helps to resolve your queries.